Missing jhsdb tool

Problem:

After downloading and installing a Zulu Bundle, it is missing the jhsdb tool/command.

 

Cause:

Our SA (Subscriber-Access) builds are only available to paid customers.  They are built to prevent dependencies to modules that can cause classpath contamination.  For more information, please review the following article, or the official GPLv2 Classspath exception link.

Therefore, jhsdb was excluded from SA bundles because it is based on the Hotspot Serviceability Agent (jdk.hotspot.agent module).

 

Solution:

Please download the respective NV (Not-Verified) JDK bundle (not recommended for redistribution) as those bundles are not guaranteed to be free of classpath contamination and will contain the jhsdb tool.

Add Comment

Comments

0 comments

Please sign in to leave a comment.

Was this article helpful?
0 out of 0 found this helpful