Which Azul Platform Prime version do I need, if my application requires Java 8.x.y_z?

For most use cases, you only need to know the required Java SE level for your application to decide which Azul Platform Prime version to install. For example 8 (also often written as 1.8.0 or 8.0.xxx or 8uXXX) or Java 11 (also written as 11.0.x for example).

If an application documentation emphasizes a requirement to a minimum specific Java SE update level within one of those SE major levels like 8, 11 or 17, for example 8u111 (1.8.0_111) with the focus on the 111, the reason for that might be a security fix or a bugfix specifically addressing a Java SE API method used by the application. In those cases for most cases just the latest Azul Platform Prime version is fine.

If you need to make a more detailed choice about the minor Java SE level version, the Azul Platform Prime Release Notes contain information about which exact Java SE level was used as based for the specific Azul Platform Prime version. It also lists the CVE fixes, those are listed in the release notes section Common Vulnerabilities and Exposures Fixes.

About the differences between Azul Platform Prime version scheme and the Java SE versions see also Using and installing different Azul Platform Prime versions in parallel.

 

 

 

Add Comment

Comments

0 comments

Please sign in to leave a comment.

Was this article helpful?
0 out of 0 found this helpful